Feeds:
文章
评论

Archive for the ‘Rails’ Category

 

First install Ruby 1.8.6 or above, then:

gem install rails

gem install mongrel

gem install mongrel_cluster
gem install mongrel_service
cd D:\tools\redmine-0.9.4   (enter home directory of the Rails app)
mongrel_rails cluster::configure -e production -p 3000 -N 3
mongrel_rails service::install -N Redmine -c D:\tools\redmine-0.9.4 -p 3000 -e production
sc config Redmine start= auto
net start Redmine

Read Full Post »

How to install the Oracle adapter 

This has been asked many times on rails-talk mailing list, so I want to summarize:
    sudo gem install activerecord-oracle-adapter –source http://gems.rubyonrails.org

(Since ActiveRecord Oracle Adapter is moving to Rubyforge. “–source http://gems.rubyonrails.org” will be omitted )
or check it out from svn:
    svn co http://svn.rubyonrails.org/rails/adapters/oracle/lib/active_record/connection_adapters/

And note that the adapter name specified in config/database.yml should be “oracle”, “oci” is deprecated.

Additional Info

Oracle “enhanced” ActiveRecord adapter is a fork of Rails Oracle Adapter, contains useful additional methods for working with new and legacy Oracle databases from Rails.

Read Full Post »

Ruby-OCI8 gem Available

Ruby-OCI8 1.0.2 gem available, a big thanks to Kubo. I’m glad to have proposed this and made a little contribution.

To install Ruby-OCI8 via gem, follow these steps:

  1. su – root
  2. rpm -ivh oracle-instantclient-basic-11.1.0.1-1.rpm oracle-instantclient-devel-11.1.0.1-1.rpm    (download link; or install oracle full client)
  3. export LD_LIBRARY_PATH=/usr/lib/oracle/11.1.0.1/client/lib:$LD_LIBRARY_PATH
  4. cd /usr/lib/oracle/11.1.0.1/client/lib
  5. ln -s libclntsh.so.11.1 libclntsh.so
  6. gem install ruby-oci8

In one word, If you’ve set up oracle db stuff and LD_LIBRARY_PATH well, simply run:

  $ sudo gem install ruby-oci8 

or

  $ sudo gem update ruby-oci8  (for update)

No “download ruby-oci8.tgz and ruby setup.rb” any more 🙂

Enjoy!

Read Full Post »

When launching a rails 2.0 app, error occurs:

C:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:319:in `activate’: can’t activate activerecord (= 1.15.6), already activated activerecord-2.0.2] (Gem::Exception)

To fix this, simply uninstall old rails gem by executing:

gem cleanup

ref: http://www.ruby-forum.com/topic/137509

Read Full Post »

Raimonds Simanovskis is "planning to create activerecord-oracle-enhanced-adapter where to put my monkey patches of original adapter". It’s a good news since Rails Oracle Adapter svn respository has been in silence for a few months.

This guy posted an idea "Oracle adapter for Ruby on Rails" on Oracle MIX 3 months ago, but seems that he didn’t get much response/support from Oracle, so he decided to run on his own.

Shall we give him a hand?

Update: He is not planning but doing it now,  see process at  http://github.com/rsim/oracle-enhanced/

Read Full Post »